What’s Vulnerable › Vulnerabilities

CVE-2025-59697

Description

Entrust nShield Connect XC, nShield 5c, and nShield HSMi through 13.6.11, or 13.7 (patched in 13.6.12 (LTS) and 13.9.0 (STS)), allow a physically proximate attacker to escalate privileges by editing the Legacy GRUB bootloader configuration to start a root shell upon boot of the host OS. This is called F06.

Affected products

How to fix

Upgrade to a fixed version: Entrust Nshield 5C Firmware 13.6.12, 13.9.0; Entrust Nshield Connect Xc Base Firmware 13.6.12, 13.9.0; Entrust Nshield Connect Xc High Firmware 13.6.12, 13.9.0; Entrust Nshield Connect Xc Mid Firmware 13.6.12, 13.9.0; Entrust Nshield Hsmi Firmware 13.6.12, 13.9.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-59697 or the next vulnerability affects your stack