What’s Vulnerable › Vulnerabilities
CVE-2025-59730: Heap-buffer-overflow write in FFmpeg SANM decoding due to lack of bounds-checking in old_codec48
- Severity: medium (CVSS 5.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-06 · updated 2026-10-19
- Weakness: CWE-787
Description
When decoding a frame for a SANM file (ANIM v0 variant), the decoded data can be larger than the buffer allocated for it. Frames encoded with codec 48 can specify their resolution (width x height). A buffer of appropriate size is allocated depending on the resolution. This codec can encode the frame contents using a run-length encoding algorithm. There are no checks that the decoded frame fits in the allocated buffer, leading to a heap-buffer-overflow. process_frame_obj initializes the buffers based on the frame resolution: We recommend upgrading to version 8.0 or beyond.
Affected products
- FFmpeg: from 829680f96a7a7ff02d1543895ec0fb713309d5c0 before 8.0 — fixed in 8.0
How to fix
Upgrade to a fixed version: FFmpeg 8.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-59730 or the next vulnerability affects your stack