What’s Vulnerable › Vulnerabilities
CVE-2025-59731: Heap-buffer-overflow write in FFmpeg EXR dwa_uncompress
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-06 · updated 2026-10-19
- Weakness: CWE-787
Description
When decoding an OpenEXR file that uses DWAA or DWAB compression, the specified raw length of run-length-encoded data is not checked when using it to calculate the output data. We read rle_raw_size from the input file at [0], we decompress and decode into the buffer td->rle_raw_data of size rle_raw_size at [1], and then at [2] we will access entries in this buffer up to (td->xsize - 1) * (td->ysize - 1) + rle_raw_size / 2, which may exceed rle_raw_size. We recommend upgrading to version 8.0 or beyond.
Affected products
- FFmpeg: from 9a32b863074ed4140141e0d3613905c6f1fe61c5 before 8.0; from 7.1.1 before 8.0 — fixed in 8.0
How to fix
Upgrade to a fixed version: FFmpeg 8.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-59731 or the next vulnerability affects your stack