What’s Vulnerable › Vulnerabilities
CVE-2025-59732: Heap-buffer-overflow write in FFmpeg EXR dwa_uncompress
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-06 · updated 2026-10-19
- Weakness: CWE-787
Description
When decoding an OpenEXR file that uses DWAA or DWAB compression, there's an implicit assumption that the height and width are divisible by 8. If the height or width of the image is not divisible by 8, the copy loops at [0] and [1] will continue to write until the next multiple of 8. The buffer td->uncompressed_data is allocated in decode_block based on the precise height and width of the image, so the "rounded-up" multiple of 8 in the copy loop can exceed the buffer bounds, and the write block starting at [2] can corrupt following heap memory. We recommend upgrading to version 8.0 or beyond.
Affected products
- FFmpeg: from 9a32b863074ed4140141e0d3613905c6f1fe61c5 before 8.0; from 7.1.1 before 8.0 — fixed in 8.0
How to fix
Upgrade to a fixed version: FFmpeg 8.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-59732 or the next vulnerability affects your stack