What’s Vulnerable › Vulnerabilities
CVE-2025-59775: Apache HTTP Server: NTLM Leakage on Windows through UNC SSRF
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-05 · updated 2026-09-25
- Weakness: CWE-918
Description
Server-Side Request Forgery (SSRF) vulnerability in Apache HTTP Server on Windows with AllowEncodedSlashes On and MergeSlashes Off allows to potentially leak NTLM hashes to a malicious server via SSRF and malicious requests or content Users are recommended to upgrade to version 2.4.66, which fixes the issue.
Affected products
- Apache HTTP Server: from 2.4.0 before 2.4.66 — fixed in 2.4.66
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.66. Check the vendor advisory for mitigations.
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- http://www.openwall.com/lists/oss-security/2025/12/04/6
Get alerted when CVE-2025-59775 or the next vulnerability affects your stack