What’s Vulnerable › Vulnerabilities
CVE-2025-59788
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-04 · updated 2026-10-18
- Weakness: CWE-749
Description
Cross-site scripting (XSS) vulnerability in a reachable files_pdfviewer example directory in Nextcloud with versions before 22.2.10.33, 23.0.12.29, 24.0.12.28, 25.0.13.23, 26.0.13.20, 27.1.11.20, 28.0.14.11, 29.0.16.8, 30.0.17, 31.0.10, and 32.0.1 allows attackers to execute arbitrary JavaScript in the context of a user's browser via a crafted PDF file to viewer.html. This issue is related to CVE-2024-4367, but the root cause of this Nextcloud issue is that the product exposes executable example code on a same-origin basis.
Affected products
- Nextcloud Server: from 30.0.0 before 30.0.17; from 31.0.0 before 31.0.10; from 32.0.0 before 32.0.1; from 22.0.0 before 22.2.10.33; from 23.0.0 before 23.0.12.29; from 24.0.0 before 24.0.12.28 — fixed in 22.2.10.33, 23.0.12.29, 24.0.12.28, 25.0.13.23, 26.0.13.20, 27.1.11.20
How to fix
Upgrade to a fixed version: Nextcloud Server 22.2.10.33, 23.0.12.29, 24.0.12.28, 25.0.13.23. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-24wp-p865-7j4r
- https://nextcloud.com
- https://www.redteam-pentesting.de/en/advisories/rt-sa-2025-003/
Get alerted when CVE-2025-59788 or the next vulnerability affects your stack