What’s Vulnerable › Vulnerabilities
CVE-2025-5982: Insufficient Granularity of Access Control in GitLab
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-12 · updated 2026-06-17
- Weakness: CWE-1220
Description
An issue has been discovered in GitLab EE affecting all versions from 12.0 before 17.10.8, 17.11 before 17.11.4, and 18.0 before 18.0.2. Under certain conditions users could bypass IP access restrictions and view sensitive information.
Affected products
- GitLab: from 12.0.0 before 17.10.8; from 17.11.0 before 17.11.4; from 18.0.0 before 18.0.2 — fixed in 17.10.8, 17.11.4, 18.0.2
How to fix
Upgrade to a fixed version: GitLab 17.10.8, 17.11.4, 18.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-5982 or the next vulnerability affects your stack