What’s Vulnerable › Vulnerabilities
CVE-2025-59831: `git-comiters` Command Injection vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-25 · updated 2026-10-11
- Weakness: CWE-77
Description
git-commiters is a Node.js function module providing committers stats for their git repository. Prior to version 0.1.2, there is a command injection vulnerability in git-commiters. This vulnerability manifests with the library's primary exported API: gitCommiters(options, callback) which allows specifying options such as cwd for current working directory and revisionRange as a revision pointer, such as HEAD. However, the library does not sanitize for user input or practice secure process execution API to separate commands from their arguments and as such, uncontrolled user input is concatenated into command execution. This issue has been patched in version 0.1.2.
Affected products
- snowyu git-commiters.js: before 0.1.2 — fixed in 0.1.2
How to fix
Upgrade to a fixed version: snowyu git-commiters.js 0.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/snowyu/git-commiters.js/commit/7f0abfedbf506e3a61ac875d91324a8dbe756e84
- https://github.com/snowyu/git-commiters.js/security/advisories/GHSA-g38c-wxjf-xrh6
- https://github.com/snowyu/git-commiters.js/security/advisories/GHSA-g38c-wxjf-xrh6
Get alerted when CVE-2025-59831 or the next vulnerability affects your stack