What’s Vulnerable › Vulnerabilities
CVE-2025-59845: Apollo Embedded Sandbox and Explorer vulnerable to CSRF via window.postMessage origin-validation bypass
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-26 · updated 2026-10-09
- Weakness: CWE-346
Description
Apollo Studio Embeddable Explorer & Embeddable Sandbox are website embeddable software solutions from Apollo GraphQL. Prior to Apollo Sandbox version 2.7.2 and Apollo Explorer version 3.7.3, a cross-site request forgery (CSRF) vulnerability was identified. The vulnerability arises from missing origin validation in the client-side code that handles window.postMessage events. A malicious website can send forged messages to the embedding page, causing the victim’s browser to execute arbitrary GraphQL queries or mutations against their GraphQL server while authenticated with the victim’s cookies. This issue has been patched in Apollo Sandbox version 2.7.2 and Apollo Explorer version 3.7.3.
Affected products
- apollographql embeddable-explorer: before 2.7.2; before 3.7.3
References
Get alerted when CVE-2025-59845 or the next vulnerability affects your stack