What’s Vulnerable › Vulnerabilities
CVE-2025-59887
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-26 · updated 2026-10-07
- Weakness: CWE-427
Description
Improper authentication of library files in the Eaton UPS Companion software installer could lead to arbitrary code execution of an attacker with the access to the software package. This security issue has been fixed in the latest version of EUC which is available on the Eaton download center.
Affected products
- Eaton UPS Companion software: before 3.0 — fixed in 3.0
How to fix
Upgrade to a fixed version: Eaton UPS Companion software 3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-59887 or the next vulnerability affects your stack