What’s Vulnerable › Vulnerabilities
CVE-2025-59933: libvips is vulnerable to Buffer Over-Read in poppler-based pdfload
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-29 · updated 2026-10-19
- Weakness: CWE-126
Description
libvips is a demand-driven, horizontally threaded image processing library. For versions 8.17.1 and below, when libvips is compiled with support for PDF input via poppler, the pdfload operation is affected by a buffer read overflow when parsing the header of a crafted PDF with a page that defines a width but not a height. Those using libvips compiled without support for PDF input are unaffected as well as thosewith support for PDF input via PDFium. This issue is fixed in version 8.17.2. A workaround for those affected is to block the VipsForeignLoadPdf operation via vips_operation_block_set, which is available in most language bindings, or to set VIPS_BLOCK_UNTRUSTED environment variable at runtime, which will block all untrusted loaders including PDF input via poppler.
Affected products
- libvips: before 8.17.2 — fixed in 8.17.2
How to fix
Upgrade to a fixed version: libvips 8.17.2. Check the vendor advisory for mitigations.
References
- https://github.com/libvips/libvips/commit/a58bfae9223a5466cc81ba9fe6dfb08233cf17d1
- https://github.com/libvips/libvips/releases/tag/v8.17.2
- https://github.com/libvips/libvips/security/advisories/GHSA-q8px-4w5q-c2r4
- https://www.vicarius.io/vsociety/posts/cve-2025-59933-detect-libvips-vulnerability
- https://www.vicarius.io/vsociety/posts/cve-2025-59933-mitigate-libvips-vulnerability
Get alerted when CVE-2025-59933 or the next vulnerability affects your stack