What’s Vulnerable › Vulnerabilities
CVE-2025-59935: GLPI Vulnerable to Unauthenticated Stored XSS on the Inventory page
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-16 · updated 2026-10-13
- Weakness: CWE-79
Description
GLPI is a free asset and IT management software package. Starting in version 10.0.0 and prior to version 10.0.21, an unauthenticated user can store an XSS payload through the inventory endpoint. Users should upgrade to 10.0.21 to receive a patch.
Affected products
- glpi-project glpi: from 10.0.0 before 10.0.21 — fixed in 10.0.21
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.21. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-59935 or the next vulnerability affects your stack