What’s Vulnerable › Vulnerabilities
CVE-2025-59944: Cursor IDE: Sensitive File Overwrite Bypass is Possible
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-03 · updated 2026-10-19
- Weakness: CWE-178
Description
Cursor is a code editor built for programming with AI. Versions 1.6.23 and below contain case-sensitive checks in the way Cursor IDE protects its sensitive files (e.g., */.cursor/mcp.json), which allows attackers to modify the content of these files through prompt injection and achieve remote code execution. A prompt injection can lead to full RCE through modifying sensitive files on case-insensitive fileystems. This issue is fixed in version 1.7.
Affected products
- cursor: through 1.6.23
References
Get alerted when CVE-2025-59944 or the next vulnerability affects your stack