What’s Vulnerable › Vulnerabilities

CVE-2025-5996: Allocation of Resources Without Limits or Throttling in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 2.1.0 before 17.10.8, 17.11 before 17.11.4, and 18.0 before 18.0.2. A lack of input validation in HTTP responses could allow an authenticated user to cause denial of service.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.10.8, 17.11.4, 18.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-5996 or the next vulnerability affects your stack