What’s Vulnerable › Vulnerabilities
CVE-2025-6000: Arbitrary Remote Code Execution via Plugin Catalog Abuse
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-01 · updated 2026-06-17
- Weakness: CWE-94
Description
A privileged Vault operator within the root namespace with write permission to {{sys/audit}} may obtain code execution on the underlying host if a plugin directory is set in Vault’s configuration. Fixed in Vault Community Edition 1.20.1 and Vault Enterprise 1.20.1, 1.19.7, 1.18.12, and 1.16.23.
Affected products
- HashiCorp Vault: from 0.8.0 before 1.16.23; from 0.8.0 before 1.20.1; from 1.17.0 before 1.18.12; from 1.19.0 before 1.19.7; 1.20.0 — fixed in 1.16.23, 1.18.12, 1.19.7, 1.20.1
How to fix
Upgrade to a fixed version: HashiCorp Vault 1.16.23, 1.18.12, 1.19.7, 1.20.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-6000 or the next vulnerability affects your stack