What’s Vulnerable › Vulnerabilities
CVE-2025-60010: Junos OS and Junos OS Evolved: Device allows login for user with expired password
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-09 · updated 2026-10-18
- Weakness: CWE-262
Description
A password aging vulnerability in the RADIUS client of Juniper Networks Junos OS and Junos OS Evolved allows an authenticated, network-based attacker to access the device without enforcing the required password change. Affected devices allow logins by users for whom the RADIUS server has responded with a reject and required the user to change the password as their password was expired. Therefore the policy mandating the password change is not enforced. This does not allow users to login with a wrong password, but only with the correct but expired one. This issue affects: Junos OS: * all versions before 22.4R3-S8, * 23.2 versions before 23.2R2-S4, * 23.4 versions before 23.4R2-S5, * 24.2 versions before 24.2R2-S1, * 24.4 versions before 24.4R1-S3, 24.4R2; Junos OS Evolved: * all versions before 22.4R3-S8-EVO, * 23.2 versions before 23.2R2-S4-EVO, * 23.4 versions before 23.4R2-S5-EVO, * 24.2 versions before 24.2R2-S1-EVO, * 24.4 versions before 24.4R1-S3-EVO, 24.4R2-EVO.
Affected products
- Juniper Junos OS: before 22.4; 22.4, 22.4-r1, 22.4-r1-s1, 22.4-r1-s2, 22.4-r2, 22.4-r2-s1 (+35) — fixed in 22.4
- Juniper Networks Junos OS Evolved: before 22.4; 22.4, 22.4-r1, 22.4-r1-s1, 22.4-r1-s2, 22.4-r2, 22.4-r2-s1 (+34) — fixed in 22.4
How to fix
Upgrade to a fixed version: Juniper Junos OS 22.4; Juniper Networks Junos OS Evolved 22.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-60010 or the next vulnerability affects your stack