What’s Vulnerable › Vulnerabilities
CVE-2025-6021: Libxml2: integer overflow in xmlbuildqname() leads to stack buffer overflow in libxml2
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-12 · updated 2026-10-12
- Weakness: CWE-787
Description
A flaw was found in libxml2's xmlBuildQName function, where integer overflows in buffer size calculations can lead to a stack-based buffer overflow. This issue can result in memory corruption or a denial of service when processing crafted input.
Affected products
- Red Hat Enterprise Linux: 8.0, 9.0, 10.0
- RedHat Enterprise Linux Eus: 8.4, 8.6, 8.8, 9.4, 9.6, 10.0
- RedHat Enterprise Linux For Arm 64: 8.0_aarch64, 9.0_aarch64, 9.4_aarch64, 10.0_aarch64
- RedHat Enterprise Linux For Arm 64 Eus: 9.4_aarch64, 9.6_aarch64, 10.0_aarch64
- RedHat Enterprise Linux For Ibm Z Systems: 8.0_s390x, 9.4_s390x, 10.0_s390x
- RedHat Enterprise Linux For Ibm Z Systems Eus: 9.0_s390x, 9.4_s390x, 9.6_s390x, 10.0_s390x
- RedHat Enterprise Linux For Power Little Endian: 8.0_ppc64le, 9.0_ppc64le, 10.0_ppc64le
- RedHat Enterprise Linux For Power Little Endian Eus: 9.4_ppc64le, 9.6_ppc64le, 10.0_ppc64le
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 8.2, 8.4, 8.6, 9.2, 9.4, 9.6
- RedHat Enterprise Linux Server For Power Little Endian Update Services For Sap Solutions: 9.4_ppc64le
- RedHat Enterprise Linux Server Tus: 8.8
- RedHat In-Vehicle Operating System: 1.0
- RedHat Jboss Core Services: all versions
- Red Hat OpenShift Container Platform 4.18: 4.12, 4.13, 4.14, 4.15, 4.16, 4.17 (+1)
- RedHat Openshift Container Platform For Arm64: 4.13, 4.14, 4.15, 4.16, 4.17, 4.18
- RedHat Openshift Container Platform For Ibm Z: 4.13, 4.14, 4.15, 4.16, 4.17, 4.18
- RedHat Openshift Container Platform For Linuxone: 4.13, 4.14, 4.15, 4.16, 4.17, 4.18
- RedHat Openshift Container Platform For Power: 4.13, 4.14, 4.15, 4.16, 4.17, 4.18
- xmlsoft libxml2: before 2.14.4 — fixed in 2.14.4
How to fix
Upgrade to a fixed version: xmlsoft libxml2 2.14.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2025:10630
- https://access.redhat.com/errata/RHSA-2025:10698
- https://access.redhat.com/errata/RHSA-2025:10699
- https://access.redhat.com/errata/RHSA-2025:11580
- https://access.redhat.com/errata/RHSA-2025:11673
- https://access.redhat.com/errata/RHSA-2025:12098
- https://access.redhat.com/errata/RHSA-2025:12099
- https://access.redhat.com/errata/RHSA-2025:12199
- https://access.redhat.com/errata/RHSA-2025:12237
- https://access.redhat.com/errata/RHSA-2025:12239
- https://access.redhat.com/errata/RHSA-2025:12240
- https://access.redhat.com/errata/RHSA-2025:12241
Get alerted when CVE-2025-6021 or the next vulnerability affects your stack