What’s Vulnerable › Vulnerabilities
CVE-2025-6033: Memory Corruption issue in XML_Serialize() in NI Circuit Design Suite
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-30 · updated 2026-06-17
- Weakness: CWE-787
Description
There is a memory corruption vulnerability due to an out of bounds write in XML_Serialize() when using SymbolEditor in NI Circuit Design Suite. This vulnerability may result in information disclosure or arbitrary code execution. Successful exploitation requires an attacker to get a user to open a specially crafted .sym file. This vulnerability affects NI Circuit Design Suite 14.3.1 and prior versions.
Affected products
- NI Circuit Design Suite: before 14.3.2 — fixed in 14.3.2
How to fix
Upgrade to a fixed version: NI Circuit Design Suite 14.3.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-6033 or the next vulnerability affects your stack