What’s Vulnerable › Vulnerabilities
CVE-2025-6038: Lisfinity Core - Lisfinity Core plugin used for pebas® Lisfinity WordPress theme <= 1.4.0 - Authenticated (Subscriber+) Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-09 · updated 2026-10-08
- Weakness: CWE-639
Description
The Lisfinity Core - Lisfinity Core plugin used for pebas® Lisfinity WordPress theme plugin for WordPress is vulnerable to privilege escalation via password update in all versions up to, and including, 1.4.0. This is due to the plugin not properly validating a user's identity prior to updating their password. This makes it possible for authenticated attackers, with Subscriber-level access and above, to change arbitrary user's passwords, including those of administrators.
Affected products
- pebas Lisfinity Core - Lisfinity Core plugin used for pebas® Lisfinity WordPress theme: through 1.4.0
References
- https://themeforest.net/item/lisfinity-classified-ads-wordpress-theme/26342611
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a3cd1c3e-5bb0-4653-8764-2ca38d9a7c77?source=cve
Get alerted when CVE-2025-6038 or the next vulnerability affects your stack