What’s Vulnerable › Vulnerabilities
CVE-2025-60455
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-18 · updated 2026-06-17
- Weakness: CWE-502
Description
Unsafe Deserialization vulnerability in Modular Max Serve before 25.6, specifically when the "--experimental-enable-kvcache-agent" feature is used allowing attackers to execute arbitrary code.
Affected products
- Modular Max: before 25.6.0 — fixed in 25.6.0
How to fix
Upgrade to a fixed version: Modular Max 25.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/modular/modular/blame/main/max/serve/kvcache_agent/kvcache_agent.py#L220
- https://github.com/modular/modular/commit/10620059fb5c47fb0c30e5d21a8ff3b8d622fba4
- https://github.com/modular/modular/commit/b20e749fa892dbe772e890a268002f732164d9f5
- https://github.com/modular/modular/commit/ee9c4ab02345dd30bed8b79771b6909ff1b930a1
- https://github.com/modular/modular/issues/4795
- https://www.oligo.security/blog/shadowmq-how-code-reuse-spread-critical-vulnerabilities-across-the-ai-ecosystem
Get alerted when CVE-2025-60455 or the next vulnerability affects your stack