What’s Vulnerable › Vulnerabilities
CVE-2025-6050: Stored Cross-Site Scripting (XSS) in Mezzanine CMS Admin Interface
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-17 · updated 2026-06-17
- Weakness: CWE-79
Description
Mezzanine CMS, in versions prior to 6.1.1, contains a Stored Cross-Site Scripting (XSS) vulnerability in the admin interface. The vulnerability exists in the "displayable_links_js" function, which fails to properly sanitize blog post titles before including them in JSON responses served via "/admin/displayable_links.js". An authenticated admin user can create a blog post with a malicious JavaScript payload in the title field, then trick another admin user into clicking a direct link to the "/admin/displayable_links.js" endpoint, causing the malicious script to execute in their browser.
Affected products
- jupo mezzanine: before 6.1.1 — fixed in 6.1.1
How to fix
Upgrade to a fixed version: jupo mezzanine 6.1.1. Check the vendor advisory for mitigations.
References
- https://advisory.checkmarx.net/advisory/CVE-2025-6050/
- https://github.com/stephenmcd/mezzanine/commit/898630d8df48cf3ddb8b9942f59168b93216e3f8
- https://github.com/stephenmcd/mezzanine/discussions/2080
Get alerted when CVE-2025-6050 or the next vulnerability affects your stack