What’s Vulnerable › Vulnerabilities
CVE-2025-6057: WPBookit <= 1.0.4 - Authenticated (Subscriber+) Arbitrary File Upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-12 · updated 2026-06-17
- Weakness: CWE-434
Description
The WPBookit plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the handle_image_upload() function in all versions up to, and including, 1.0.4. This makes it possible for authenticated attackers, with Subscriber-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.
Affected products
- iqonicdesign WPBookit: before 1.0.5 — fixed in 1.0.5
How to fix
Upgrade to a fixed version: iqonicdesign WPBookit 1.0.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wpbookit/trunk/core/admin/classes/controllers/class.wpb-profile-controller.php#L85
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3326098%40wpbookit&new=3326098%40wpbookit&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/wpbookit/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/fac81cc0-c6c9-4009-aacb-52adc70c0261?source=cve
Get alerted when CVE-2025-6057 or the next vulnerability affects your stack