What’s Vulnerable › Vulnerabilities
CVE-2025-61146
- Severity: medium (CVSS 4.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-23 · updated 2026-06-17
- Weakness: CWE-401
Description
saitoha libsixel until v1.8.7 was discovered to contain a memory leak via the component malloc_stub.c.
Affected products
- saitoha libsixel: before 1.8.7 — fixed in 1.8.7
How to fix
Upgrade to a fixed version: saitoha libsixel 1.8.7. Check the vendor advisory for mitigations.
References
- https://gist.github.com/optionGo/1100e5be05c5558501a95f5e99160584
- https://github.com/saitoha/libsixel/commit/e0ba6685262a3679cc5b9009c0c5b7dc8a3f262e
- https://github.com/saitoha/libsixel/issues/207
Get alerted when CVE-2025-61146 or the next vulnerability affects your stack