What’s Vulnerable › Vulnerabilities
CVE-2025-6140: spdlog pattern_formatter-inl.h scoped_padder resource consumption
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-16 · updated 2026-06-17
- Weakness: CWE-400
Description
A vulnerability, which was classified as problematic, was found in spdlog up to 1.15.1. This affects the function scoped_padder in the library include/spdlog/pattern_formatter-inl.h. The manipulation leads to resource consumption. It is possible to launch the attack on the local host. The exploit has been disclosed to the public and may be used. Upgrading to version 1.15.2 is able to address this issue. The identifier of the patch is 10320184df1eb4638e253a34b1eb44ce78954094. It is recommended to upgrade the affected component.
Affected products
- spdlog: before 1.15.2 — fixed in 1.15.2
How to fix
Upgrade to a fixed version: spdlog 1.15.2. Check the vendor advisory for mitigations.
References
- https://github.com/gabime/spdlog/commit/10320184df1eb4638e253a34b1eb44ce78954094
- https://github.com/gabime/spdlog/issues/3360
- https://github.com/gabime/spdlog/issues/3360#issuecomment-2729579422
- https://github.com/gabime/spdlog/releases/tag/v1.15.2
- https://vuldb.com/?ctiid.312609
- https://vuldb.com/?id.312609
- https://vuldb.com/?submit.592999
- https://github.com/gabime/spdlog/issues/3360
Get alerted when CVE-2025-6140 or the next vulnerability affects your stack