What’s Vulnerable › Vulnerabilities
CVE-2025-61624: Fortinet Multiple Products Path Traversal Vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-10-16
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-14 · updated 2026-10-17
- Weakness: CWE-22
Description
An Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') [CWE-22] vulnerability in Fortinet FortiOS 7.6.0 through 7.6.4, FortiOS 7.4.0 through 7.4.9, FortiOS 7.2 all versions, FortiOS 7.0 all versions, FortiOS 6.4 all versions, FortiPAM 1.7.0, FortiPAM 1.6 all versions, FortiPAM 1.5 all versions, FortiPAM 1.4 all versions, FortiPAM 1.3 all versions, FortiPAM 1.2 all versions, FortiPAM 1.1 all versions, FortiPAM 1.0 all versions, FortiProxy 7.6.0 through 7.6.4, FortiProxy 7.4.0 through 7.4.11, FortiProxy 7.2 all versions, FortiProxy 7.0 all versions, FortiSwitchManager 7.2.0 through 7.2.7, FortiSwitchManager 7.0.0 through 7.0.6 may allow an authenticated attacker with admin profile and at least read-write permissions to write or delete arbitrary files via specific CLI commands.
Affected products
- Fortinet FortiOS (FortiGate): from 6.4.0 before 7.4.10; from 7.6.0 before 7.6.5 — fixed in 7.4.10, 7.6.5
- Fortinet FortiPAM: from 1.0.0 before 1.7.1 — fixed in 1.7.1
- Fortinet FortiProxy: from 7.0.0 before 7.4.12; from 7.6.0 before 7.6.5 — fixed in 7.4.12, 7.6.5
- Fortinet FortiSwitchManager: from 7.0.0 before 7.0.7; from 7.2.0 before 7.2.8 — fixed in 7.0.7, 7.2.8
- Siemens Ruggedcom Ape1808 Firmware: all versions
How to fix
Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 7.4.10, 7.6.5; Fortinet FortiPAM 1.7.1; Fortinet FortiProxy 7.4.12, 7.6.5; Fortinet FortiSwitchManager 7.0.7, 7.2.8. Check the vendor advisory for mitigations.
References
- https://fortiguard.fortinet.com/psirt/FG-IR-26-122
- https://cert-portal.siemens.com/productcert/html/ssa-975644.html
- https://unit42.paloaltonetworks.com/fortimanager-cve-2024-47575-peerstitch-malware/#post-188095-_guyq53ar8k05
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-61624
Get alerted when CVE-2025-61624 or the next vulnerability affects your stack