What’s Vulnerable › Vulnerabilities
CVE-2025-61638: Sanitizer::validateAttributes data-XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki, Wikimedia Foundation Parsoid. This vulnerability is associated with program files includes/parser/Sanitizer.Php, src/Core/Sanitizer.Php. This issue affects MediaWiki: from * before 1.39.14, 1.43.4, 1.44.1; Parsoid: from * before 0.16.6, 0.20.4, 0.21.1.
Affected products
- Wikimedia Foundation MediaWiki: before 1.39.14; from 1.39.15 before 1.43.4; from 1.43.5 before 1.44.1 — fixed in 1.39.14, 1.43.4, 1.44.1
- Wikimedia Parsoid: before 0.16.6; from 0.16.6 (excl.) before 0.20.4; from 0.20.4 (excl.) before 0.21.1 — fixed in 0.16.6, 0.20.4, 0.21.1
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.39.14, 1.43.4, 1.44.1; Wikimedia Parsoid 0.16.6, 0.20.4, 0.21.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-61638 or the next vulnerability affects your stack