What’s Vulnerable › Vulnerabilities
CVE-2025-61639: Suppressed blocked IP is visible in Special:BlockList, RC, and other places
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-03 · updated 2026-06-17
- Weakness: CWE-200
Description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/logging/ManualLogEntry.Php, includes/recentchanges/RecentChangeFactory.Php, includes/recentchanges/RecentChangeStore.Php. This issue affects MediaWiki: from * before 1.39.14, 1.43.4, 1.44.1.
Affected products
- Wikimedia Foundation MediaWiki: before 1.39.14; from 1.39.15 before 1.43.4; from 1.43.5 before 1.44.1 — fixed in 1.39.14, 1.43.4, 1.44.1
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.39.14, 1.43.4, 1.44.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-61639 or the next vulnerability affects your stack