What’s Vulnerable › Vulnerabilities
CVE-2025-61640: Stored XSS through system messages in Special:RecentChangesLinked (MW Core)
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files resources/src/mediawiki.Rcfilters/ui/RclToOrFromWidget.Js. This issue affects MediaWiki: from * before 1.39.14, 1.43.4, 1.44.1.
Affected products
- Wikimedia Foundation MediaWiki: before 1.39.14; from 1.39.15 before 1.43.4; from 1.43.5 before 1.44.1 — fixed in 1.39.14, 1.43.4, 1.44.1
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.39.14, 1.43.4, 1.44.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-61640 or the next vulnerability affects your stack