What’s Vulnerable › Vulnerabilities
CVE-2025-61653: Extension:TextExtracts does not check for authorizeRead when returning extracts
- Severity: low (CVSS 2.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-03 · updated 2026-06-17
- Weakness: CWE-22
Description
Vulnerability in Wikimedia Foundation TextExtracts. This vulnerability is associated with program files includes/ApiQueryExtracts.Php. This issue affects TextExtracts: from * before 1.39.14, 1.43.4, 1.44.1.
Affected products
- Wikimedia Foundation TextExtracts: before 1.39.14, 1.43.4, 1.44.1 — fixed in 1.43.4, 1.44.1, 1.39.14
How to fix
Upgrade to a fixed version: Wikimedia Foundation TextExtracts 1.43.4, 1.44.1, 1.39.14. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-61653 or the next vulnerability affects your stack