What’s Vulnerable › Vulnerabilities
CVE-2025-61655: Stored XSS through system messages in VisualEditor
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation VisualEditor. This vulnerability is associated with program files includes/ApiVisualEditorEdit.Php, modules/ve-mw/init/targets/ve.Init.Mw.DesktopArticleTarget.Js, modules/ve-mw/ui/dialogs/ve.Ui.MWSaveDialog.Js. This issue affects VisualEditor: from * before 1.39.14, 1.43.4, 1.44.1.
Affected products
- Wikimedia Foundation VisualEditor: from 1.39.0 before 1.39.14; from 1.43.0 before 1.43.4; 1.44.0 — fixed in 1.39.14, 1.43.4
How to fix
Upgrade to a fixed version: Wikimedia Foundation VisualEditor 1.39.14, 1.43.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-61655 or the next vulnerability affects your stack