What’s Vulnerable › Vulnerabilities
CVE-2025-6167: themanojdesai python-a2a api.py create_workflow path traversal
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-17 · updated 2026-06-17
- Weakness: CWE-22
Description
A vulnerability classified as critical has been found in themanojdesai python-a2a up to 0.5.5. Affected is the function create_workflow of the file python_a2a/agent_flow/server/api.py. The manipulation leads to path traversal. Upgrading to version 0.5.6 is able to address this issue. It is recommended to upgrade the affected component.
Affected products
- themanojdesai python-a2a: through 0.5.5
References
- https://github.com/themanojdesai/python-a2a/issues/40
- https://github.com/themanojdesai/python-a2a/issues/40#issuecomment-2904804388
- https://github.com/themanojdesai/python-a2a/releases/tag/v0.5.6
- https://vuldb.com/?ctiid.312642
- https://vuldb.com/?id.312642
- https://vuldb.com/?submit.593613
- https://github.com/themanojdesai/python-a2a/issues/40
Get alerted when CVE-2025-6167 or the next vulnerability affects your stack