What’s Vulnerable › Vulnerabilities
CVE-2025-61673: Karapace is vulnerable to Authentication Bypass
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-03 · updated 2026-10-08
- Weakness: CWE-288
Description
Karapace is an open-source implementation of Kafka REST and Schema Registry. Versions 5.0.0 and 5.0.1 contain an authentication bypass vulnerability when configured to use OAuth 2.0 Bearer Token authentication. If a request is sent without an Authorization header, the token validation logic is skipped entirely, allowing an unauthenticated user to read and write to Schema Registry endpoints that should otherwise be protected. This effectively renders the OAuth authentication mechanism ineffective. This issue is fixed in version 5.0.2.
Affected products
- Aiven-Open karapace: from 5.0.0, < 5.0.2
References
- https://github.com/Aiven-Open/karapace/pull/1143/commits/c4038e9ce9fa504b433d59ac2944e337292922c7
- https://github.com/Aiven-Open/karapace/releases/tag/5.0.2
- https://github.com/Aiven-Open/karapace/security/advisories/GHSA-vq25-vcrw-gj53
Get alerted when CVE-2025-61673 or the next vulnerability affects your stack