What’s Vulnerable › Vulnerabilities

CVE-2025-61674: October CMS Vulnerable to Stored XSS via Editor and Branding Styles

Description

October is a Content Management System (CMS) and web platform. Prior to versions 3.7.13 and 4.0.12, a cross-site scripting (XSS) vulnerability was identified in October CMS backend configuration forms. A user with the Global Editor Settings permission could inject malicious HTML/JS into the stylesheet input at Markup Styles. A specially crafted input could break out of the intended <style> context, allowing arbitrary script execution across backend pages for all users. This issue has been patched in versions 3.7.13 and 4.0.12.

Affected products

How to fix

Upgrade to a fixed version: octobercms october 3.17.3, 4.0.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-61674 or the next vulnerability affects your stack