What’s Vulnerable › Vulnerabilities
CVE-2025-61730: Handshake messages may be processed at the incorrect encryption level in crypto/tls
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-28 · updated 2026-06-17
Description
During the TLS 1.3 handshake if multiple messages are sent in records that span encryption level boundaries (for instance the Client Hello and Encrypted Extensions messages), the subsequent messages may be processed before the encryption level changes. This can cause some minor information disclosure if a network-local attacker can inject messages during the handshake.
Affected products
- Go: before 1.24.12; from 1.25.0 before 1.25.6 — fixed in 1.24.12, 1.25.6
How to fix
Upgrade to a fixed version: Go 1.24.12, 1.25.6. Check the vendor advisory for mitigations.
References
- https://go.dev/cl/724120
- https://go.dev/issue/76443
- https://groups.google.com/g/golang-announce/c/Vd2tYVM8eUc
- https://pkg.go.dev/vuln/GO-2026-4340
Get alerted when CVE-2025-61730 or the next vulnerability affects your stack