What’s Vulnerable › Vulnerabilities
CVE-2025-61772: Rack's multipart parser buffers unbounded per-part headers, enabling DoS (memory exhaustion)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-07 · updated 2026-10-19
- Weakness: CWE-400
Description
Rack is a modular Ruby web server interface. In versions prior to 2.2.19, 3.1.17, and 3.2.2, `Rack::Multipart::Parser` can accumulate unbounded data when a multipart part’s header block never terminates with the required blank line (`CRLFCRLF`). The parser keeps appending incoming bytes to memory without a size cap, allowing a remote attacker to exhaust memory and cause a denial of service (DoS). Attackers can send incomplete multipart headers to trigger high memory use, leading to process termination (OOM) or severe slowdown. The effect scales with request size limits and concurrency. All applications handling multipart uploads may be affected. Versions 2.2.19, 3.1.17, and 3.2.2 cap per-part header size (e.g., 64 KiB). As a workaround, restrict maximum request sizes at the proxy or web server layer (e.g., Nginx `client_max_body_size`).
Affected products
- rack: before 2.2.19; from 3.1.0 before 3.1.17; from 3.2.0 before 3.2.2 — fixed in 2.2.19, 3.1.17, 3.2.2
- Rubygems Rack: before 2.2.19; from 3.1 before 3.1.17; from 3.2 before 3.2.2; 0.1.0, 0.2.0, 0.3.0, 0.4.0, 0.9.0, 0.9.1 (+132) — fixed in 2.2.19, 3.1.17, 3.2.2
How to fix
Upgrade to a fixed version: rack 2.2.19, 3.1.17, 3.2.2; Rubygems Rack 2.2.19, 3.1.17, 3.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/rack/rack/commit/589127f4ac8b5cf11cf88fb0cd116ffed4d2181e
- https://github.com/rack/rack/commit/d869fed663b113b95a74ad53e1b5cae6ab31f29e
- https://github.com/rack/rack/commit/e08f78c656c9394d6737c022bde087e0f33336fd
- https://github.com/rack/rack/security/advisories/GHSA-wpv5-97wm-hp9c
Get alerted when CVE-2025-61772 or the next vulnerability affects your stack