What’s Vulnerable › Vulnerabilities
CVE-2025-61788: Opencast Paella Player 7 vulnerable to Cross-Site-Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-08 · updated 2026-10-19
- Weakness: CWE-79
Description
Opencast is a free, open-source platform to support the management of educational audio and video content. Prior to Opencast 17.8 and 18.2, the paella would include and render some user inputs (metadata like title, description, etc.) unfiltered and unmodified. The vulnerability allows attackers to inject and malicious HTML and JavaScript in the player, which would then be executed in the browsers of users watching the prepared media. This can then be used to modify the site or to execute actions in the name of logged-in users. To inject malicious metadata, an attacker needs write access to the system. For example, the ability to upload media and modify metadata. This cannot be exploited by unauthenticated users. This issue is fixed in Opencast 17.8 and 18.2.
Affected products
- opencast: before 17.8; from 18.0 before 18.2 — fixed in 17.8, 18.2
How to fix
Upgrade to a fixed version: opencast 17.8, 18.2. Check the vendor advisory for mitigations.
References
- https://github.com/opencast/opencast/commit/2809520fa88d108d8104c760f00c10bad42c14f9
- https://github.com/opencast/opencast/security/advisories/GHSA-m2vg-rmq6-p62r
Get alerted when CVE-2025-61788 or the next vulnerability affects your stack