What’s Vulnerable › Vulnerabilities
CVE-2025-61820: Illustrator | Heap-based Buffer Overflow (CWE-122)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-11 · updated 2026-10-18
- Weakness: CWE-122
Description
Illustrator versions 28.7.10, 29.8.2 and earlier are affected by a Heap-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Illustrator: from 28.0 through 28.7.10; from 29.0 before 29.8.3 — fixed in 29.8.3
How to fix
Upgrade to a fixed version: Adobe Illustrator 29.8.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-61820 or the next vulnerability affects your stack