What’s Vulnerable › Vulnerabilities
CVE-2025-61828: Illustrator on iPad | Out-of-bounds Write (CWE-787)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-11 · updated 2026-10-18
- Weakness: CWE-787
Description
Illustrator on iPad versions 3.0.9 and earlier are affected by an out-of-bounds write vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Illustrator on iPad: before 3.0.10 — fixed in 3.0.10
How to fix
Upgrade to a fixed version: Adobe Illustrator on iPad 3.0.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-61828 or the next vulnerability affects your stack