What’s Vulnerable › Vulnerabilities

CVE-2025-6186: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 18.1 before 18.1.4, and 18.2 before 18.2.2 that could have allowed authenticated users to achieve account takeover by injecting malicious HTML into work item names.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.1.4, 18.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-6186 or the next vulnerability affects your stack