What’s Vulnerable › Vulnerabilities
CVE-2025-61913: Flowise is vulnerable to arbitrary file read, arbitrary file write
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-08 · updated 2026-10-08
- Weakness: CWE-22
Description
Flowise is a drag & drop user interface to build a customized large language model flow. In versions prior to 3.0.8, WriteFileTool and ReadFileTool in Flowise do not restrict file path access, allowing authenticated attackers to exploit this vulnerability to read and write arbitrary files to any path in the file system, potentially leading to remote command execution. Flowise 3.0.8 fixes this vulnerability.
Affected products
- FlowiseAI Flowise: before 3.0.8 — fixed in 3.0.8
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.0.8. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/commit/1fb12cd93143592a18995f63b781d25b354d48a3
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise%403.0.8
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-j44m-5v8f-gc9c
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-jv9m-vf54-chjj
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-j44m-5v8f-gc9c
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-jv9m-vf54-chjj
Get alerted when CVE-2025-61913 or the next vulnerability affects your stack