What’s Vulnerable › Vulnerabilities
CVE-2025-61915: OpenPrinting CUPS vulnerable to stack based out-of-bound write
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-29 · updated 2026-10-07
- Weakness: CWE-124
Description
OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a user in the lpadmin group can use the cups web ui to change the config and insert a malicious line. Then the cupsd process which runs as root will parse the new config and cause an out-of-bound write. This issue has been patched in version 2.4.15.
Affected products
- OpenPrinting cups: before 2.4.15 — fixed in 2.4.15
How to fix
Upgrade to a fixed version: OpenPrinting cups 2.4.15. Check the vendor advisory for mitigations.
References
- https://github.com/OpenPrinting/cups/commit/db8d560262c22a21ee1e55dfd62fa98d9359bcb0
- https://github.com/OpenPrinting/cups/releases/tag/v2.4.15
- https://github.com/OpenPrinting/cups/security/advisories/GHSA-hxm8-vfpq-jrfc
- http://www.openwall.com/lists/oss-security/2025/11/27/5
- https://github.com/OpenPrinting/cups/security/advisories/GHSA-hxm8-vfpq-jrfc
Get alerted when CVE-2025-61915 or the next vulnerability affects your stack