What’s Vulnerable › Vulnerabilities
CVE-2025-61922: PrestaShop Checkout allows customer account takeover via email
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-16 · updated 2026-10-09
- Weakness: CWE-287
Description
PrestaShop Checkout is the PrestaShop official payment module in partnership with PayPal. Starting in version 1.3.0 and prior to versions 4.4.1 and 5.0.5, missing validation on the Express Checkout feature allows silent login, enabling account takeover via email. The vulnerability is fixed in versions 4.4.1 and 5.0.5. No known workarounds exist.
Affected products
- PrestaShopCorp ps_checkout: from 1.3.0 before 7.4.4.1; from 7.5.0.1 before 7.5.0.5; from 8.3.1.0 before 8.4.4.1; from 8.5.0.0 before 8.5.0.5; from 9.4.3.1 before 9.5.0.5 — fixed in 7.4.4.1, 7.5.0.5, 8.4.4.1, 8.5.0.5, 9.5.0.5
How to fix
Upgrade to a fixed version: PrestaShopCorp ps_checkout 7.4.4.1, 7.5.0.5, 8.4.4.1, 8.5.0.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-61922 or the next vulnerability affects your stack