What’s Vulnerable › Vulnerabilities
CVE-2025-61923: PrestaShop Checkout Backoffice directory traversal allows arbitrary file disclosure
- Severity: medium (CVSS 4.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-16 · updated 2026-10-09
- Weakness: CWE-22
Description
PrestaShop Checkout is the PrestaShop official payment module in partnership with PayPal. In versions prior to 4.4.1 and 5.0.5, the backoffice is missing validation on input resulting in a directory traversal and arbitrary file disclosure. The vulnerability is fixed in versions 4.4.1 and 5.0.5. No known workarounds exist.
Affected products
- PrestaShopCorp ps_checkout: before 7.4.4.1; from 7.5.0.1 before 7.5.0.5; from 8.3.1.0 before 8.4.4.1; from 8.5.0.0 before 8.5.0.5; from 9.4.3.1 before 9.5.0.5 — fixed in 7.4.4.1, 7.5.0.5, 8.4.4.1, 8.5.0.5, 9.5.0.5
How to fix
Upgrade to a fixed version: PrestaShopCorp ps_checkout 7.4.4.1, 7.5.0.5, 8.4.4.1, 8.5.0.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-61923 or the next vulnerability affects your stack