What’s Vulnerable › Vulnerabilities

CVE-2025-61924: PrestaShop Checkout Target PayPal merchant account hijacking from backoffice

Description

PrestaShop Checkout is the PrestaShop official payment module in partnership with PayPal. In versions prior to 4.4.1 and 5.0.5, the Target PayPal merchant account hijacking from backoffice due to wrong usage of the PHP array_search(). The vulnerability is fixed in versions 4.4.1 and 5.0.5. No known workarounds exist.

Affected products

How to fix

Upgrade to a fixed version: PrestaShopCorp ps_checkout 7.4.4.1, 7.5.0.5, 8.4.4.1, 8.5.0.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-61924 or the next vulnerability affects your stack