What’s Vulnerable › Vulnerabilities
CVE-2025-6200: GeoDirectory < 2.8.120 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The GeoDirectory WordPress plugin before 2.8.120 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- paoltaia GeoDirectory – WP Business Directory Plugin and Classified Listings Directory: before 2.8.120 — fixed in 2.8.120
How to fix
Upgrade to a fixed version: paoltaia GeoDirectory – WP Business Directory Plugin and Classified Listings Directory 2.8.120. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-6200 or the next vulnerability affects your stack