What’s Vulnerable › Vulnerabilities
CVE-2025-6207: WP Import Export Lite <= 3.9.28 - Authenticated (Subscriber+) Arbitrary File Upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-05 · updated 2026-06-17
- Weakness: CWE-434
Description
The WP Import Export Lite plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'wpie_tempalte_import' function in all versions up to, and including, 3.9.28. This makes it possible for authenticated attackers, with Subscriber-level access and above, and permissions granted by an Administrator, to upload arbitrary files on the affected site's server which may make remote code execution possible.
Affected products
- vjinfotech WP Import Export Lite: before 3.9.29 — fixed in 3.9.29
How to fix
Upgrade to a fixed version: vjinfotech WP Import Export Lite 3.9.29. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-import-export-lite/trunk/includes/classes/class-wpie-common-action.php#L386
- https://plugins.trac.wordpress.org/changeset/3323402/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/188eef67-de66-49c2-aa6c-2cf3b886ff66?source=cve
Get alerted when CVE-2025-6207 or the next vulnerability affects your stack