What’s Vulnerable › Vulnerabilities
CVE-2025-62161: youki container escape via "masked path" abuse due to mount race conditions
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-06 · updated 2026-10-19
- Weakness: CWE-61
Description
Youki is a container runtime written in Rust. In versions 0.5.6 and below, the initial validation of the source /dev/null is insufficient, allowing container escape when youki utilizes bind mounting the container's /dev/null as a file mask. This issue is fixed in version 0.5.7.
Affected products
- youki-dev youki: before 0.5.7 — fixed in 0.5.7
How to fix
Upgrade to a fixed version: youki-dev youki 0.5.7. Check the vendor advisory for mitigations.
References
- https://github.com/youki-dev/youki/commit/5886c91073b9be748bd8d5aed49c4a820548030a
- https://github.com/youki-dev/youki/security/advisories/GHSA-4g74-7cff-xcv8
- https://github.com/youki-dev/youki/security/advisories/GHSA-4g74-7cff-xcv8
- https://github.com/youki-dev/youki/security/advisories/GHSA-4g74-7cff-xcv8
- https://github.com/youki-dev/youki/security/advisories/GHSA-4g74-7cff-xcv8
- https://github.com/youki-dev/youki/security/advisories/GHSA-4g74-7cff-xcv8
- https://github.com/youki-dev/youki/security/advisories/GHSA-4g74-7cff-xcv8
- https://github.com/youki-dev/youki/security/advisories/GHSA-4g74-7cff-xcv8
- https://github.com/youki-dev/youki/security/advisories/GHSA-4g74-7cff-xcv8
Get alerted when CVE-2025-62161 or the next vulnerability affects your stack