What’s Vulnerable › Vulnerabilities
CVE-2025-62168: Squid vulnerable to information disclosure via authentication credential leakage in error handling
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 63.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-17 · updated 2026-10-19
- Weakness: CWE-209
Description
Squid is a caching proxy for the Web. In Squid versions prior to 7.2, a failure to redact HTTP authentication credentials in error handling allows information disclosure. The vulnerability allows a script to bypass browser security protections and learn the credentials a trusted client uses to authenticate. This potentially allows a remote client to identify security tokens or credentials used internally by a web application using Squid for backend load balancing. These attacks do not require Squid to be configured with HTTP authentication. The vulnerability is fixed in version 7.2. As a workaround, disable debug information in administrator mailto links generated by Squid by configuring squid.conf with email_err_data off.
Affected products
- Squid: before 7.2 — fixed in 7.2
How to fix
Upgrade to a fixed version: Squid 7.2. Check the vendor advisory for mitigations.
References
- https://github.com/squid-cache/squid/commit/0951a0681011dfca3d78c84fd7f1e19c78a4443f
- https://github.com/squid-cache/squid/security/advisories/GHSA-c8cc-phh7-xmxr
- http://www.openwall.com/lists/oss-security/2025/11/05/6
Get alerted when CVE-2025-62168 or the next vulnerability affects your stack