What’s Vulnerable › Vulnerabilities
CVE-2025-62169: OctoPrint-SpoolManager Plugin APIs do not enforce authentication
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-23 · updated 2026-10-08
- Weakness: CWE-287
Description
OctoPrint-SpoolManager is a plugin for managing spools and all their usage metadata. In versions 1.8.0a2 and older of the testing branch and versions 1.7.7 and older of the stable branch, the APIs of the OctoPrint-SpoolManager plugin do not correctly enforce authentication or authorization checks. This issue has been patched in versions 1.8.0a3 of the testing branch and 1.7.8 of the stable branch. The impact of this vulnerability is greatly reduced when using OctoPrint version 1.11.2 and newer.
Affected products
- WildRikku OctoPrint-SpoolManager: before 1.8.0a3; before 1.7.8
References
- https://github.com/WildRikku/OctoPrint-SpoolManager/commit/b725e113316e177ce81238a2dbbbdb63d92c40b0
- https://github.com/WildRikku/OctoPrint-SpoolManager/releases/tag/1.7.8
- https://github.com/WildRikku/OctoPrint-SpoolManager/releases/tag/1.8.0a3
- https://github.com/WildRikku/OctoPrint-SpoolManager/security/advisories/GHSA-2rrc-f24f-94f6
Get alerted when CVE-2025-62169 or the next vulnerability affects your stack