What’s Vulnerable › Vulnerabilities
CVE-2025-62181: Pega Platform versions 7.1.0 through Infinity 25.1.0 are affected by a User Enumeration where during user authentication process, a difference in response time could allow a remote unauthenticated user to determine if a username is valid or not.
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-10 · updated 2026-09-28
- Weakness: CWE-204
Description
Pega Platform versions 7.1.0 through Infinity 25.1.0 are affected by a User Enumeration. This issue occurs during user authentication process, where a difference in response time could allow a remote unauthenticated user to determine if a username is valid or not. This only applies to deprecated basic-authentication feature and other more secure authentication mechanisms are recommended. A fix is being provided in the 24.1.4, 24.2.4, and 25.1.1 patch releases. Please note: Basic credentials authentication service type is deprecated started in 24.2 version: https://docs.pega.com/bundle/platform/page/platform/release-notes/security/whats-new-security-242.html.
Affected products
- Pegasystems Pega Infinity: from 7.1.0 before Infinity 25.1.1 — fixed in Infinity 25.1.1
How to fix
Upgrade to a fixed version: Pegasystems Pega Infinity Infinity 25.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-62181 or the next vulnerability affects your stack